Applicant Site Slowness

Incident Report for DATIS

Resolved

Our Engineering team has resolved reports of slowness or inability to access Applicant sites.
Posted May 19, 2025 - 16:26 UTC

Investigating

We are currently investigating reports of slowness or inability to access applicant sites. Our Engineering team is working diligently to resolve this and we will post more updates shortly.
Posted May 19, 2025 - 16:18 UTC
This incident affected: DATIS e3 Applicant.