As of approximately 8pm ET yesterday evening, October 20th, Amazon Web Services reported all service had returned to normal operation. Our Engineering team has continued to monitor and has not observed any lingering impact to DATIS e3. At this time, this incident has been determined to be resolved. We appreciate your patience and your partnership as we monitored this issue. Thank you.
Posted Oct 21, 2025 - 13:02 UTC
Monitoring
Our Engineering team is closely monitoring updates from AWS regarding the system performance degradation. These AWS issues are currently impacting some aspects of the DATIS e3 platform, including the generation of certain reports. At this time, AWS has reported they have implemented additional resolution steps and are observing incremental improvements. We will continue to monitor their progress and provide another update here once this is confirmed to be fully resolved. We appreciate your patience and partnership.
Posted Oct 20, 2025 - 19:29 UTC
Identified
Early morning on October 20th, 2025, an Amazon Web Services (AWS) service disruption impacted the performance and availability of DATIS e3, e3 Applicant, and ePunch. This impact was confirmed to be resolved by our Engineering team by 5:22am ET.
However, AWS is currently reporting that system performance may again be affected as they continue mitigation steps to resolve root cause for all supported applications. We have observed slowness within the DATIS e3 platform at login and report generation as a result.
Our Engineering team is monitoring the AWS situation closely and we will post another update as soon as we have one available.