Visibility Issues on Some Pages

Incident Report for DATIS

Resolved

We have confirmed the resolution implemented has resolved the errors previously reported. This may take a few moments to update your current session.
Posted May 20, 2025 - 19:27 UTC

Identified

Our Engineering team has identified the resolution for the page rendering issues reported by some users. This fix has been implemented.
Posted May 20, 2025 - 19:22 UTC

Investigating

We are currently investigating reports of some page elements not rendering fully for all users on Desktop. Our team is actively working to resolve and we will post an update shortly.
Posted May 20, 2025 - 19:08 UTC
This incident affected: DATIS e3 Desktop.